How to Install

Requirements

  • Ruby version 1.9.3-p0 or later for normal use (mandatory)
  • GNU Make version 3 or later to use adlintized Makefile (optional but recommended)

Install in MS Windows

Use with the standard Command Prompt

1. Install Ruby

If Ruby version 1.9.3-p0 or later has already been installed, you can skip this section.

Get RubyInstaller for Windows version 1.9.3-p0 or later from RubyInstaller Downloads page.

Execute RubyInstaller and install Ruby according to the instructions of the installer.

2. Install DEVELOPMENT KIT

If DEVELOPMENT KIT has already been installed, you can skip this section.

Get DEVELOPMENT KIT from RubyInstaller Downloads page.

Execute the DevKit-*.exe, then DEVELOPMENT KIT including GNU Make will be extracted into the specified directory.

3. Set the PATH environment variable

Append the following paths to PATH environment variable.

  • "bin" in the Ruby installation directory
  • "bin" in the DevKit installation directory
  • "mingw\bin" in the DevKit installation directory

4. Install AdLint

Start the Command Prompt, and execute following command to fetch and install the latest AdLint.

 > gem install adlint --no-ri --no-rdoc

If you have to use an HTTP proxy, specify --http-proxy [http://user name:password@proxy host:port number] to gem command.

> gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128


Use with MinGW

1. Install Ruby

If Ruby version 1.9.3-p0 or later has already been installed, you can skip this section.

Get RubyInstaller for Windows version 1.9.3-p0 or later from RubyInstaller Downloads page.

Execute RubyInstaller and install Ruby according to the instructions of the installer.

2. Set the PATH environment variable

Append "bin" in the Ruby installation directory to the PATH environment variable.

3. Install AdLint

In the MinGW Shell, execute following command to fetch and install the latest AdLint.

 $ gem install adlint --no-ri --no-rdoc

If you have to use an HTTP proxy, specify --http-proxy [http://user name:password@proxy host:port number] to gem command.

$ gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128


Use with Cygwin

Because the version of Ruby bundled with Cygwin is 1.8.x, you need to install Ruby version 1.9.3-p0 or later.

1. Install Ruby

Get the source archive of Ruby version 1.9.3-p0 or later from Download Ruby page and build it.

2. Install AdLint

In the Cygwin Bash Shell, execute following command to fetch and install the latest AdLint.

 $ gem install adlint --no-ri --no-rdoc

If you have to use an HTTP proxy, specify --http-proxy [http://user name:password@proxy host:port number] to gem command.

$ gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128

Install in Unix

Version of the Ruby bundled with your OS may be older than 1.9.3-p0. Check the version number by the following command.

% ruby -v
ruby 1.8.7 (2011-06-30 patchlevel 352) [i386-linux]

1. Install Ruby

If Ruby version 1.9.3-p0 or later has already been installed, you can skip this section.

Get the source archive of Ruby version 1.9.3-p0 or later from Download Ruby page and build it.

2. Install AdLint

Execute following command to fetch and install the latest AdLint.

 % gem install adlint --no-ri --no-rdoc

or

 % sudo gem install adlint --no-ri --no-rdoc

If you have to use an HTTP proxy, specify --http-proxy [http://user name:password@proxy host:port number] to gem command.

% gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128

Other resources

FAQ : About Installation


>> Return to Top