インストール方法

動作要件

Ruby 1.9.3-p0 以降のバージョンが必要です。

また、並行解析などの高度な機能を使用するために、GNU Make バージョン 3 以降のインストールをお勧めします。

MS Windows 環境へのインストール

コマンドプロンプトで使用する場合

1. Ruby をインストールします

既にRuby バージョン 1.9.3-p0 以降がインストールされている場合、この作業は不要です。

RubyInstaller for Windows サイトの ダウンロードページ から 1.9.3-p0 以降のバージョンの RubyInstaller を入手します。

RubyInstaller を実行し、インストーラの指示に従い Ruby をインストールします。

2. DEVELOPMENT KIT (DevKit) をインストールします

既に DEVELOPMENT KIT がインストールされている場合、この作業は不要です。

RubyInstaller for Windows サイトの ダウンロードページ から DEVELOPMENT KIT を入手します。

DevKit-*.exe を実行すると、GNU Make を含む DEVELOPMENT KIT が指定したディレクトリに展開されます。

3. PATH 環境変数を設定します

以下の 3 つのパスを、PATH 環境変数に追加してください。

  • Ruby をインストールしたディレクトリ中の bin
  • DEVELOPMENT KIT をインストールしたディレクトリ中の bin
  • DEVELOPMENT KIT をインストールしたディレクトリ中の mingw\bin

4. AdLint をインストールします

コマンドプロンプトを起動し、下記のコマンドにより AdLint の最新バージョンをダウンロードしインストールします。

 > gem install adlint --no-ri --no-rdoc

HTTP プロキシを使用する場合は、gem コマンドに --http-proxy [http://ユーザ:パスワード@プロキシホスト:ポート番号] を指定します。

> gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128


MinGW で使用する場合

1. Ruby をインストールします

既にRuby バージョン 1.9.3-p0 以降がインストールされている場合、この作業は不要です。

RubyInstaller for Windows サイトの ダウンロードページ から 1.9.3-p0 以降のバージョンの RubyInstaller を入手します。

RubyInstaller を実行し、インストーラの指示に従い Ruby をインストールします。

2. PATH 環境変数を設定します

Ruby をインストールしたディレクトリ中の binPATH 環境変数に追加してください。

3. AdLint をインストールします

MinGW Shell から下記のコマンドにより AdLint の最新バージョンをダウンロードしインストールします。

 $ gem install adlint --no-ri --no-rdoc

HTTP プロキシを使用する場合は、gem コマンドに --http-proxy [http://ユーザ:パスワード@プロキシホスト:ポート番号] を指定します。

$ gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128


Cygwin で使用する場合

Cygwin に同封される Ruby はバージョン 1.8.x のため、以下の方法で Ruby バージョン 1.9.3-p0 以降をインストールする必要があります。

1. Ruby をインストールします

Ruby 1.9.3-p0 以降のバージョンのソースコードを ダウンロードページ から入手します。

Ruby インストールガイド に従い、Ruby をインストールします。

2. AdLint をインストールします

Cygwin Bash Shell から下記のコマンドにより AdLint の最新バージョンをダウンロードしインストールします。

 $ gem install adlint --no-ri --no-rdoc

HTTP プロキシを使用する場合は、gem コマンドに --http-proxy [http://ユーザ:パスワード@プロキシホスト:ポート番号] を指定します。

$ gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128

Unix 環境へのインストール

OS に標準添付されている Ruby は、バージョンが古い可能性があります。下記のコマンドでバージョンを確認してください。

% ruby -v
ruby 1.8.7 (2011-06-30 patchlevel 352) [i386-linux]

1. Ruby をインストールします

既に Ruby バージョン 1.9.3-p0 以降がインストールされている場合、この作業は不要です。

Ruby 1.9.3-p0 以降のバージョンのソースコードを ダウンロードページ から入手します。

Ruby インストールガイド に従い、Ruby をインストールします。

2. AdLint をインストールします

シェルから下記のコマンドにより AdLint の最新バージョンをダウンロードしインストールします。

 % gem install adlint --no-ri --no-rdoc

または

 % sudo gem install adlint --no-ri --no-rdoc

HTTP プロキシを使用する場合は、gem コマンドに --http-proxy [http://ユーザ:パスワード@プロキシホスト:ポート番号] を指定します。

% gem install adlint --no-ri --no-rdoc --http-proxy http://user:passwd@proxy:3128

参考情報


>> トップへ戻る